5-1 继承与派生
Problem Description
通过本题目的练习可以掌握继承与派生的概念,派生类的定义和使用方法,其中派生类构造函数的定义是重点。
要求定义一个基类Point,它有两个私有的float型数据成员X,Y;一个构造函数用于对数据成员初始化;有一个成员函数void Move(float xOff, float yOff)实现分别对X,Y值的改变,其中参数xOff和yOff分别代表偏移量。另外两个成员函数GetX() 、GetY()分别返回X和Y的值。
Rectangle类是基类Point的公有派生类。它增加了两个float型的私有数据成员W,H; 增加了两个成员函数float GetH() 、float GetW()分别返回W和H的值;并定义了自己的构造函数,实现对各个数据成员的初始化。
编写主函数main()根据以下的输入输出提示,完成整个程序。
Input
6个float型的数据,分别代表矩形的横坐标X、纵坐标Y、宽度W,高度H、横向偏移量的值、纵向偏移量的值;每个数据之间用一个空格间隔
Output
输出数据共有4个,每个数据之间用一个空格间隔。分别代表偏移以后的矩形的横坐标X、纵坐标Y、宽度W,高度H的值
Example Input
5 6 2 3 1 2
Example Output
6 8 2 3
Hint
输出 -3 4 0 0
#include <bits/stdc++.h>
using namespace std;
class point
{
public:
point(float a, float b)
{
x = a;
y = b;
}
void Move(float x1, float y1)
{
x += x1;
y += y1;
}
float getx()
{
return x;
}
float gety()
{
return y;
}
private:
float x,y;
};
class rectangle: public point
{
public:
rectangle(float a, float b, float c, float d):point(a, b)
{
w = c;
h = d;
}
float getw()
{
return w;
}
float geth()
{
return h;
}
private:
float w, h;
};
int main()
{
float x, y, w, h, x1, y1;
cin >> x >> y >> w >> h >> x1 >> y1;
if(w < 0)
{
w = 0;
}
if(h < 0)
{
h = 0;
}
rectangle t(x, y, w, h);
t.Move(x1, y1);
cout << t.getx() << " " <<t. gety() << " " << t.getw() << " " << t.geth() << endl;
return 0;
}