字符串排序

字符串排序

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
输入3个字符串,按字典序从小到大进行排序。
Input
输入数据有一行,分别为3个字符串,用空格分隔,每个字符串长度不超过100。
Output
输出排序后的三个字符串,用空格分隔。
Sample Input
abcd cdef bcde
Sample Output
abcd bcde cdef
import java.util.Arrays;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  // TODO Auto-generated method stub
  Scanner sc = new Scanner(System.in);
  String  s, s1 = "", s2="", s3="";
  int flag=1;
  s = sc.nextLine();
  int i, n = s.length();
  for(i = 0; i < n; i++)
  {
   if(s.charAt(i) != ' ')
   {
    if(flag==1)
    {
     s1+=s.charAt(i);
    }
    if(flag==2)
    {
     s2+=s.charAt(i);
    }
    if(flag==3)
    {
     s3+=s.charAt(i);
    }
   }
   if(s.charAt(i) == ' ')
   {
    flag++;
   }
  }
  if(s1.compareTo(s2) <= 0)
  {
   if(s1.compareTo(s3) <= 0)
   {
    System.out.print(s1+" ");
    if(s2.compareTo(s3) <= 0)
    {
     System.out.print(s2+" ");
     System.out.println(s3);
    }
    else
    {
     System.out.print(s3+" ");
     System.out.println(s2);
    }
   }
   else
   {
    System.out.print(s3+" ");
    System.out.print(s1+" ");
    System.out.println(s2);
   }
  }
  else
  {
   if(s2.compareTo(s3) <= 0)
   {
    System.out.print(s2+" ");
    {
     if(s1.compareTo(s3) <= 0)
     {
      System.out.print(s1+" ");
      System.out.println(s3);
     }
     else
     {
      System.out.print(s3+" ");
      System.out.println(s1);
     }
    }
   }
   else
   {
    System.out.print(s3+" ");
    System.out.print(s2+" ");
    System.out.println(s1);
   }
  }
  /*System.out.println(s1);
  System.out.println(s2);
  System.out.println(s3);*/
  sc.close();
 }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值