hdu1874畅通工程续

畅通工程续

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20972    Accepted Submission(s): 7292


Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
  
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
  
  
2 -1
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>

using namespace std;
const int maxn = 210;
const int maxm = 1100;
const int INF = 0x7fffffff;
int gn, gm;
bool inque[maxn];
int dist[maxn];

queue<int> Q;
vector<pair<int, int> > g[maxn + 10];
//2013-08-28 18:43:15	Accepted	1874	0MS	264K	1712 B	C++	Achiberx
void spfa(const int s, const int t) {
    int i;
    memset(inque, false, sizeof(inque));
    for(i = 0; i < gn; i++) dist[i] = INF;
    dist[s] = 0;
    while(!Q.empty()) Q.pop();//清空队列.
    Q.push(s);
    inque[s] = true;
    while(!Q.empty()) {
        int u = Q.front();
        Q.pop();
        for(i = 0; i < (int)g[u].size(); i++) {
            int t = g[u][i].first;
            if(dist[u] != INF && g[u][i].second != INF && dist[u]+g[u][i].second < dist[t]) {
                dist[t] = dist[u] + g[u][i].second;
                if(!inque[t]) {
                    inque[t] = true;
                    Q.push(t);
                }
            }
        }
        inque[u] = false;
    }
    if(dist[t] != INF) {
        printf("%d\n", dist[t]);
    }
    else printf("-1\n");
}

void init() {
    int i;
    for(i = 0; i < maxn; i++) {
        g[i].clear();
    }
}

int main()
{
    int i;
    int x, y, w;
    pair<int,int> t;
    while(scanf("%d%d", &gn, &gm) != EOF) {
        init();//清空容器.
        for(i = 0; i < gm; i++) {//开始建图的时候建成了有向图。
            scanf("%d%d%d", &x, &y, &w);
            t.first = y;
            t.second = w;
            g[x].push_back(t);
            t.first = x;
            g[y].push_back(t);
        }
        int s, tt;
        scanf("%d%d", &s, &tt);
        spfa(s, tt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值