Ultra-QuickSort
Time Limit: 7000MS | Memory Limit: 65536K | |
Total Submissions: 31628 | Accepted: 11281 |
Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Ultra-QuickSort produces the output
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5 9 1 0 5 4 3 1 2 3 0
Sample Output
6 0
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 500010;
long long cnt = 0;
int a[maxn], t[maxn];
void merge_sort(int *A, int x, int y, int* T) {//contain [x,y]
if(x==y) return ;
// printf("x = %d, y = %d\n", x, y);
if(y-x>=1) {
int m = (x+y)/2;
int p = x, q = m+1, i = x;
merge_sort(A, x, m, T);
merge_sort(A, m+1, y, T);
while(p <= m || q <= y) {
if(p<=m && q<=y && A[p]<=A[q]) {
T[i++] = A[p++];
}
if(p<=m && q<=y && A[p]>A[q]) {
cnt = cnt + (m-p+1);
// printf("cnt = %d\n", cnt);
T[i++] = A[q++];
}
while(q>y && p<=m) {
T[i++] = A[p++];
}
while(p>m && q<=y) {
T[i++] = A[q++];
}
}
for( i = x; i <= y; i++) {
A[i] = T[i];
}
}
}
int main()
{
int n;
while((scanf("%d", &n) != EOF) && n) {
for(int i = 0; i < n; i++) {
scanf("%d", &a[i]);
}
merge_sort(a, 0, n-1, t);
printf("%lld\n", cnt);
cnt = 0;
}
return 0;
}
/**********************
5
9 1 0 5 4
8
9 1 0 5 4 3 8 7
**************/