OJ Problem 3445 c#统计字符串中数字字符的个数

题目描述

假设有一个GetNumber方法(参数为字符串strSource),编写一个静态方法可以用来统计字符串strSource中数字字符的个数。 

输入

输入一个字符串strSource

输出

strSource字符串中数字字符的个数

样例输入

asffkl8asjkfjklas3jdf9lkj!

样例输出

3

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Security.Cryptography;
using System.IO;
namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string strSource = Console.ReadLine();
            int count=0;
            for(int i=0;i<strSource.Length;i++)
            {
                if(strSource[i]>='0'&&strSource[i]<='9')
                {
                    count++;
                }
            }
            Console.WriteLine(count);
        }
    }
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值