OJ problem 3493 FileStream读文件

题目描述

使用FileStream类,编写一个控制台应用,能够读取当前文件夹下myFile.dic文件内容,并在屏幕上显示。

输入

输出

文件内容

样例输入

copy

样例输出

hello world!

hi ,good

首先,创建myFile.dic文件(否则运行时出现找不到文件,出现错误),文件内容为样例输出所示,将文件保存在当前文件夹下,修改copy to output directory属性为copy if newer

以下为参考代码:

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.IO;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string path="myFile.dic";
            FileStream fs = new FileStream(path, FileMode.Open, FileAccess.Read);
            //long i = fs.Length;
            byte[] b = new byte[fs.Length];
            fs.Read(b, 0, b.Length);
            fs.Dispose();

            UTF8Encoding tmp = new UTF8Encoding();
            Console.WriteLine(tmp.GetString(b));
            Console.ReadKey();
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值