OJ-2751 指针练习--字符串统计

2751: 指针练习--字符串统计

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 228   Solved: 145
[ Submit][ Status][ Web Board]

Description

实现一个统计函数。统计字符串中大写字母、小写字母和其他字符的个数。

主函数已给定如下,提交时不需要包含下述主函数
int main()
{
    char str[80];
    int numA,numa,numt;
    cin.getline(str,80);
    count(str,&numA,&numa,&numt);
    cout<<"大写字母个数为 "<<numA<<endl
        <<"小写字母个数为 "<<numa<<endl
        <<"其他字符个数为 "<<numt<<endl;
    return 0;
}

Input

一行字符串

Output

大写字母、小写字母和其他字符的个数

Sample Input

WVGA:800*480,HDTV:1080i,33.75kHz

Sample Output

大写字母个数为 9
小写字母个数为 3
其他字符个数为 20

//注意运算符的优先级

#include<iostream>
#include<cstring>
using namespace std;
void count(char str[80],int *numA,int *numa,int *numt);
int main()
{
    char str[80];
    int numA,numa,numt;
    cin.getline(str,80);
    count(str,&numA,&numa,&numt);
    cout<<"大写字母个数为 "<<numA<<endl
        <<"小写字母个数为 "<<numa<<endl
        <<"其他字符个数为 "<<numt<<endl;
    return 0;
}
void count(char str[80],int *numA,int *numa,int *numt)
{
    *numA=0;*numa=0;*numt=0;
    int n=strlen(str);
    for(int i=0;i<n;i++)
    {
        if(str[i]>='A'&&str[i]<='Z')
            *numA+=1;
        else if(str[i]>='a'&&str[i]<='z')
            *numa+=1;
        else
            *numt=*numt+1;
    }
    return ;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值