二分法求最小值最大

POJ2456题,求最小值最大,链接:http://poj.org/problem?id=2456
Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33846 Accepted: 15491
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance
    Sample Input

5 3
1
2
8
4
9
Sample Output

3
题目大意:有N个牛棚,每个位置的坐标给你,现在给你M头牛,每头牛放进一个牛棚里,使各个牛之间的距离的最小值最大。

#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 100005
int n,c;
int a[maxn];
int main(){
	int left=0x3f3f3f3f,right=0;
	cin>>n>>c;
	for(int i=0;i<n;i++){
		cin>>a[i];
	}
	sort(a,a+n);
	right=a[n-1]-a[0];
	for(int i=1;i<n;i++){
		if(a[i]-a[i-1]<left) left=a[i]-a[i-1];
	}
	while(left<=right){
		int mind=(left+right)/2;
		int cnt=1;
		//int cha=0;
		int first=0;
		for(int i=1;i<n;i++){
			if(a[i]-a[first]>=mind){
				first=i;
				cnt++;//记录最小值为mind的时候,可以放多少的牛
			}
		}
		if(cnt>=c) left=mind+1;//如果cnt>c说明mind小了,可以放更多的牛,如果cnt=mind说明刚好可以放C斗牛,但不一定使最优解,所以答案还要再可行区间向右移动
		else right=mind-1;//CNT<C说明mind取大了,right=mind,答案向左移动
	}
	cout<<right<<endl;
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值