hdu 1010 Tempter of the Bone题解(dfs+奇偶剪枝)



Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76222    Accepted Submission(s): 20885


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;  
'S': the start point of the doggie;  
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

题意:给你n,m,t,n,m代表一个n*m的迷宫,‘S’代表起点,‘D’代表终点,‘X’代表墙,‘.’代表可走的路。要求从S走到D,每个点只能经过一次,恰好走t步到达D。


题解:先写出最暴力的dfs,每个点可以继续上下左右走。大多数人这么写了,但却TLE了,这题最重要的是剪枝,他的考点是奇偶剪枝。

奇偶剪枝:从偶数点到偶数点或者奇数点到奇数点需要偶数步,从偶数点到奇数点或奇数点到偶数点需要奇数步。(请耐心细读

                   换种说法,起点终点为同奇或同偶则需要偶数步。

偶数点:横纵坐标加起来是偶数,比如(0,0),(1,3)。

奇数点:横纵坐标加起来是奇数,比如(0,1),(0,3)。

所以先找出起点(x1,y1)和终点(x2,y2)。

同奇同偶有个特点,(x1+y1+x2+y2)是偶数(因为奇数+奇数=偶数,偶数加偶数=偶数)

也可总结成(x1+y1+x2+y2)与t同偶或同奇才有可能恰好t步到达。即(x1+y1+x2+y2+t)%2==0成立,则有可能到达。


AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
#define x1 xx
#define y1 yy
int n,m,t,x1,x2,y1,y2,panduan;
char a[10][10];
int f[4][2]={-1,0,0,-1,0,1,1,0};

void dfs(int x,int y,int cut){
    if(panduan==1)
        return ;

    if(cut==0){
        if(x==x2&&y==y2)
        {panduan=1;return ;}
        else
            return ;
    }
    if((abs(x2-x)+abs(y2-y))>cut)
        return ;
    for(int i=0;i<4;i++){
        int xx,yy;
        xx=x+f[i][0];
        yy=y+f[i][1];
         if(xx>=0&&yy>=0&&a[xx][yy]=='.'){
            a[xx][yy]='X';
            dfs(xx,yy,cut-1);
            if(panduan==1)
                return ;
            a[xx][yy]='.';
        }
    }
}

int main(){
    while(scanf("%d%d%d",&n,&m,&t)&&(n|m|t)){
        int x=0;
        panduan=0;
        getchar();
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                scanf("%c",&a[i][j]);
                if(a[i][j]=='S'){
                    x1=i,y1=j;
                }
                else if(a[i][j]=='D'){
                    x2=i,y2=j;
                    a[i][j]='.';
                }
                else if(a[i][j]=='X'){
                    x++;
                }
            }
            getchar();
        }
        if((x1+x2+y1+y2+t)%2||n*m-x<t)
            {printf("NO\n");}
        else{
            dfs(x1,y1,t);
            if(panduan)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值