并查集模版及其示例

1  先通过查找根节点将该连在一起的连在一起

2 连接完之后,统计总共有多少伙


    #include<iostream>
    #include<cstdio>
    using namespace std;
    int tree[50010];


    int find(int x)            //寻找根节点
    {
        if(x == tree[x])
            return x;
        else
            return tree[x] = find(tree[x]);
    }


    void union(int x,int y)  // 将一伙的连在一起
    {
        int a=find(x);
        int b=find(y);
        if(a!=b) tree[b]=a;
        return;
    }

    int main()
    {
        int n;    总共有n个元素
        while(scanf("%d", &n) != EOF)
            {
            int sum = 0;
            for(int i = 0; i < n; i++)

               tree[i]=i;                        //初始化
            for(int i = 0; i < m; i++)
            {
                int x, y;
                cin >> x >> y;
              union(x, y);
            }

        }
    }




1   统计多少与X一伙的


  bool same(int x, int y)      //判断是否是一伙

     {

         return find(x) == find(y);

      }


  for(int i = 0;i < n;i++)         //该连在一起的连在一起后,统计总共有多少伙
             {

               if( same(i, X))

              sum++;

             }

            printf("%d\n",,sum);

2  统计有多少伙


for(int i = 1; i <= n; i++)

{

if(tree[i] == i)

ans++;

}



The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 26901 Accepted: 13142

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
题意:有N个人分成M组,M,N下面共有M列,N个人编号从0到N-1。M列每列第一个数k代表该列有k个数,编号为0的称为可能患有病的人为嫌疑犯,
只要一组里面有一个嫌疑犯,那么全组都是。现在为了预防病的传染,需要判断有多少个嫌疑犯。我们已经知道编号为0的人是嫌疑犯 
且 一个人可能分属不同的几个组。也就是说:假设有有两个组有同一个嫌疑犯,那么这两个组的人都会变成嫌疑犯。
思路:合并每一组里面的人 + 从头查询, 并查集模版题。







#include<bits/stdc++.h>

    #define MAXN 30000+10
    using namespace std;
    int tree[MAXN];
    int x[MAXN];
    int N, M;
    void init()
    {
        for(int i = 0; i < N; i++)
            tree[i] = i;
    }
   int find(int p)
    {
        if(tree[p] == p)
            return p;
        else
        {
           return tree[p] = find(tree[p]);
        }
    }

    void Union(int x, int y)
    {
        int fx = find(x);
        int fy = find(y);
        if(fx != fy)
            tree[fx] = fy;
    }
    bool same(int x, int y)
    {
        return find(x) == find(y);
    }
    int main()
    {
        while(scanf("%d%d", &N, &M), N||M)
        {
            init();
            int k;
            while(M--)
            {
                scanf("%d", &k);
                for(int i = 0; i < k; i++)
                    scanf("%d", &x[i]);
                for(int i = 0; i < k-1; i++)
                    Union(x[i], x[i+1]);
            }
            int ans = 0;
            for(int i = 0; i < N; i++)
            {
                if(same(i, 0))
                    ans++;
            }
            printf("%d\n", ans);
        }
        return 0;
    }










  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值