安装基于Ubuntu的微信小程序开发工具

安装基于Ubuntu的微信小程序开发工具

由于比较熟悉linux开发环境而微信开发工具官方只提供了windows和mac,就在网上找了下相关内容,花了老半天安装,其中有个坑搞了半天。记录一下,提醒自己。

git上有大牛写了,Linux微信web开发者工具

Description
Linux微信web开发者工具, 可在 linux 桌面环境跑起 微信开发者工具, 原理是 微信开发者工具 本质是 nw.js 程序, 把它移植到 linux 下没大问题. 负责编译 wxml 和 wxss 的 wcc 和 wcsc (可能还有其他功能), 则利用 wine 来跑即可.

具体步骤可直接看git上的readme

  1. 安装Wine
  2. 下载项目 git clone https://github.com/cytle/wechat_web_devtools.git
  3. 进入目录 cd wechat_web_devtools
  4. 安装wine sudo apt-get install wine-binfmt
    sudo update-binfmts –import /usr/share/binfmts/wine

  5. 自动下载最新 nw.js , 同时部署目录 ~/.config/微信web开发者工具/
    ./bin/wxdt install

我主要是在第4步卡住了,每次都是
报错
这一步不搞定的话,就会出现wcc编译出错。
搜了网上的情况,需要
sudo apt-get update
另外,可能是只是下载源不对,更换合适的源即可。

然鹅。。。。。。我试了好几个源都还是不行。
wine-binfmt的官网上看
wine-binfmt
好像没有ubuntu 16.04(我用的ubuntu16.04系统)版本,我怀疑我找不到下载文件就是这个原因。

好吧,跳过中间各种曲折过程说结果—-最后找到了一篇博客Ubuntu 16.04 运行微信开发者工具编译出错的解决办法 根据这个博文的方法,成功解决了第四步的问题。

试了 腾讯云nodejs启动模板,可以运行

相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页