HDOJ 2052 Picture

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input

3 2

Sample Output

±–+
| |
| |
±–+

大水题,没什么意思,两种方法,一种直接暴力输出(我就用的这种);另一种根据输入数据,编写好二维数组然后输出。平时的输出三角形,矩阵什么的一般都用第二种,第一种只是偷懒的方法。

代码

#include<iostream>
using namespace std;
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        cout<<"+";
        for(int i=0;i<n;i++)
        {
            cout<<"-";
        }
        cout<<"+"<<endl;
        while(m--)
        {
            cout<<"|";
            for(int i=0;i<n;i++)
                cout<<" ";
            cout<<"|"<<endl;
        }
        cout<<"+";
        for(int i=0;i<n;i++)
        {
            cout<<"-";
        }
        cout<<"+"<<endl<<endl;
    }
}

代码看着长,就是直接暴力输出,不费什么脑子,这个题水水过去就好,注意输出格式。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值