HDOJ 2054 A == B ?

Problem Description

Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print “YES”, or print “NO”.

##Sample Input
1 2
2 2
3 3
4 3

 Sample Output

NO
YES
YES
NO

解题思路:

因为题目中并没有规定A,B的范围,这是个大数问题。
所以输入的时候需要用字符串输入。字符串输入就需要删掉末尾可能的0或者小数点。 我用了STL中的string,做起来比较方便。

#include<iostream>
#include<string>
using namespace std;
void zero(string &n)
{
    //判断是否有小数点
    if(n.find('.')!=string::npos)
    {
        for(int i=n.size()-1;i>=n.find('.');i--)
        {
            //如果末尾有0,擦掉
            if(n[i]=='0')
                n.erase(i);
            else if(n[i]=='.')
            {
                n.erase(i);
                break;
            }
            else
                break;
        }
    }
}

int main()
{
    string a,b;
    while(cin>>a>>b)
    {
        zero(a);
        zero(b);
        if(a.compare(b)==0)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值