HDOJ 2056 Rectangles

Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00
56.25

刚开始看有点没懂,看了别人的解释才明白,输入是两条对角线上的端点。
这个题用排序的方法分别把x,y坐标排序,然后判断两个矩形是否相交,如果相交,那么一定是中间两个点的x,y值构成的矩形的面积。

#include<iostream>
#include<algorithm>
#include<iomanip>
#include<cmath>
using namespace std;

int main()
{
    double x[4],y[4],x1,x2,y1,y2;
    while(cin>>x[0]>>y[0]>>x[1]>>y[1]>>x[2]>>y[2]>>x[3]>>y[3])
    {
        //计算两个矩形的边长
        x1=fabs(x[0]-x[1]);
        x2=fabs(x[2]-x[3]);
        y1=fabs(y[0]-y[1]);
        y2=fabs(y[2]-y[3]);
        //排序
        sort(x,x+4);
        sort(y,y+4);
        //判断是否相交
        if(x1+x2>x[3]-x[0]&&y1+y2>y[3]-y[0])
            cout<<fixed<<setprecision(2)<<(x[2]-x[1])*(y[2]-y[1])<<endl;
        else
            cout<<"0.00"<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值