PAT A1025-算法笔记顺序P103

 

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

解题注意事项:

该题思路难度不大,主要是多次排序,如果保证复杂度较低,代码长度较低完成。

排序使用sort函数,在外部定义一个bool cmp来确定排序同成绩时会按字典序进行排序。

注意结构体的构建!!!

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

struct Student
{
    char id[15];
    int  score;
    int  final_rank;
    int  location_number;
    int  local_rank;
} stu[30010];

bool cmp(Student a,Student b)
{
    if (a.score != b.score)
        return a.score > b.score;
    else
        return strcmp(a.id, b.id) < 0;
        //此处cmp利用bool函数判断当一个数据进行排序时其前后数据是否相同,不同则正常排序,相同则利用字典序排序。
}
int main()
{
    int n,num = 0;
    scanf("%d",&n);

    for(int i = 0 ; i < n; i++)
    {
        int k;
        scanf("%d",&k);
        for(int j = 0; j < k; j++)
        {
            scanf("%s %d",stu[num].id,&stu[num].score);
            stu[num].location_number = i+1 ;
            num++;
        }

        sort(stu + num - k, stu + num, cmp);  
       //利用stu + num - k来避免两次排序互相干扰,同时完成了num对所有学生数量的统计!!!
        stu[num-k].local_rank = 1;

        for(int j = num - k + 1; j < num; j++)
        {
            if(stu[j].score == stu[j-1].score)
                stu[j].local_rank = stu[j-1].local_rank;
            else
                stu[j].local_rank = j+1-(num-k);
        }
    }
    printf("%d\n",num);
    sort(stu, stu + num, cmp);
    stu[0].final_rank = 1;

    for(int j = 1; j<=num; j++)
    {
        if(stu[j].score == stu[j-1].score)
            stu[j].final_rank = stu[j-1].final_rank;
        else
            stu[j].final_rank = j+1;
        printf("%s ",stu[j-1].id);
        printf("%d %d %d\n",stu[j-1].final_rank,stu[j-1].location_number,stu[j-1].local_rank);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值