kuangbin带你飞历练之路(一)简单搜索---Dungeon Master(地牢逃生)

这是一道关于三维迷宫的问题,与二维bfs区别不大,只是将原本的四个搜索方向变成了六个而已(上下左右前后)。

题目链接:http://poj.org/problem?id=2251

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45339 Accepted: 17112

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!
输入样例:
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
输出样例:
Escaped in 11 minute(s).
Trapped!

建议:

    这题思路与二维bfs一样,因此我便不再赘述了,这里只说一下我对于这题的些许改进,就是在读入地牢地图的时候将距离数组初始化、起点、终点的坐标这三点处理好,这样不仅让代码看起来更整洁,也提升了些许的速度。

下面上代码:(16ms)

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <queue>
using namespace std;
char maze[35][35][35];
int dx[6] = { 0,0,-1,1,0,0 };
int dy[6] = { -1,1,0,0,0,0 };
int dz[6] = { 0,0,0,0,-1,1 };
int d[35][35][35];
int l, r, c;
int gx, gy, gz;
struct point
{
	point(int a, int b, int c)
	{
		x = a;
		y = b;
		z = c;
	}
	int x, y, z;
};
int main()
{
	while (true)
	{
		scanf("%d%d%d", &l, &r, &c);
		if (l == 0 && r == 0 && c == 0) break;
		queue<point>que;  //队列如果定义在这里的话应该是在栈区,如果过长则可能爆栈,本题经计算不会
						  //如果定义为全局变量的话则应在每个样例后进行清空
		for (int i = 0; i < l; i++)
		{
			for (int j = 0; j < r; j++)
			{
				scanf("%s", &maze[i][j]);
				for (int k = 0; k < c; k++)
				{
					d[i][j][k] = 1000000000;
					if (maze[i][j][k] == 'S')
					{
						que.push(point(i, j, k));
						d[i][j][k] = 0;
					}
					if (maze[i][j][k] == 'E')
					{
						gx = i, gy = j, gz = k;
					}
				}
			}
		}
		while (!que.empty())
		{
			point p=que.front();
			que.pop();
			if (maze[p.x][p.y][p.z] == 'E')
				break;
			for (int i = 0; i < 6; i++)
			{
				int nx = p.x + dx[i];
				int ny = p.y + dy[i];
				int nz = p.z + dz[i];
				if (nx >= 0 && nx < l&&ny >= 0 && ny < r&&nz >= 0 && nz < c&&maze[nx][ny][nz] != '#'&&d[nx][ny][nz] == 1000000000)
				{
					que.push(point(nx, ny, nz));
					d[nx][ny][nz] = d[p.x][p.y][p.z] + 1;
				}
			}
		}
		if (d[gx][gy][gz] == 1000000000)
			printf("Trapped!\n");
		else printf("Escaped in %d minute(s).\n", d[gx][gy][gz]);
	}
	return 0;
}

迷宫



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值