hdu1505最大子矩阵(输入超级坑)

所有的wa全是输入错误,交了好几天,都快和别人的代码一样了,还是错,一点一点的对换,终于找到哪错了,真!!!!!我c
整整2页连续的wa,全是我交的。记忆深刻。
这里写图片描述

这里写图片描述
City Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7622 Accepted Submission(s): 3298

Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you’re building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input
2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output
45
0

Source
Southeastern Europe 2004

Recommend
zl | We have carefully selected several similar problems for you: 1506 1069 1203 1176 1231

Statistic | Submit | Discuss | Note
解题思路:
最大子矩阵,输出面积乘以3;
解题代码:

#include<stdio.h>
#include<string.h>
#define N 1010
char map[N][N],d[4];
int dp[N][N],l[N],r[N];
int main()
{
    int t,s,i,j,n,m,max,T;
    scanf("%d",&T);
    while(T--)
    {
        max=0;
        scanf("%d%d",&n,&m);

        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {

                scanf("%s",d);
                if(d[0]=='R'||d[0]=='F')
                map[i][j]=d[0];

            }
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=m;i++)
            {
                for(j=1;j<=n;j++)
                {
                    if(map[j][i]=='F')
                        dp[j][i]=dp[j-1][i]+1;
                    else
                        dp[j][i]=0;
                }
            }
        for(i=1;i<=n;i++)
            {
                l[1]=1;r[m]=m;
                for(j=2;j<=m;j++)
                {
                    if(dp[i][j]==0)
                        continue;
                    t=j;
                    while(t>1&&dp[i][j]<=dp[i][t-1])
                        t=l[t-1];
                    l[j]=t;
                }
                for(j=m-1;j>=1;j--)
                {
                    if(dp[i][j]==0)
                        continue;
                    t=j;
                    while(t<m&&dp[i][j]<=dp[i][t+1])
                        t=r[t+1];
                    r[j]=t;
                }
                for(j=1;j<=m;j++)
                    if((r[j]-l[j]+1)*dp[i][j]>max)
                        max=(r[j]-l[j]+1)*dp[i][j];
            }

    printf("%d\n",max*3);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值