UVA 10970 Big Chocolate

Mohammad has recently visited Switzerland. As he loves his friends very much, he decided to buy
some chocolate for them, but as this fine chocolate is very expensive(You know Mohammad is a littleBIT stingy!), he could only afford buying one chocolate, albeit a very big one (part of it can beseen infigure 1) for all of them as a souvenir. Now, he wants to give each of his friends exactly one part of thischocolate and as he believes all human beings are equal (!), he wants to split it into equal parts.The chocolate is an NxM rectangle constructed from NxM unit-sized squares. You can assume thatMohammad has also NxM friends waiting to receive their piece of chocolate.

To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines that separate the squares). Then, he should do the same with each part separately until he reaches
unit size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the minimum number of cuts required to accomplish this task.

Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares apart.

The Input

The input consists of several test cases. In each line of input, there are two integers , the
number of rows in the chocolate andM ≤ 3001≤ N ≤ 3001 , the number of columns in the chocolate. The inputshould be processed until end of file is encountered.

The Output

For each line of input, your program should produce one line of output containing an integer indicating
the minimum number of cuts needed to split the entire chocolate into unit size pieces.

Sample Input

2 2
1 1
1 5

Sample Output

3
0
4

代码实现

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int M,N,test;
    while(scanf("%d%d",&M,&N)!=EOF)
    {
        test=M*N-1;
            printf("%d\n",test);
    }
    return 0;
}

题解:
均分问题:
巧克力只用横切或者竖切;
所以输出 M*N-1就是输出

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值