Keywords Search(AC自动机模版题)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 73920    Accepted Submission(s): 25371


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
 
 
1 5 she he say shr her yasherhs
 

Sample Output
 
 
3

// 记住不要用STLString,不然会超时= =
#include <iostream>
#include <queue>
#include <string.h>
using namespace std;
// Trie树节点
struct node {
	int cnt; //这个节点的单词数
	node* next[26]; // 子节点数组
	node* fail;     // 失配指针
	node() {
		cnt = 0;
		fail = NULL;
		memset(next, NULL, sizeof(next));
	}
};
node* root;
char str[1000010];

void init() {
	root = new node;
}
// 普通的插入
void insert(char* str) {
	node* p = root;
	int length = strlen(str);
	for (unsigned i = 0; i < length; i++) {
		int now = str[i] - 'a';
		if (p->next[now] == NULL)
			p->next[now] = new node;
		p = p->next[now];
	}
	p->cnt++;
}

// fail指针初始化,用广度优先遍历(BFS)
void build() {
	root->fail = NULL;
	queue<node*> q;
	q.push(root);
	while (!q.empty()) {
		// 当前指针
		node* cur = q.front();
		q.pop();
		for (int i = 0; i < 26; i++) {
			//找到实际存在的字符结点 
			if (cur->next[i] != NULL) {
				// 如果当前结点为root结点,特殊化处理
				if (cur == root)
					cur->next[i]->fail = root;
				// 如果不为root结点
				else {
					// 依次找第一长前缀,第二长前缀...直到达到root
					node* p = cur->fail;
					while (p != NULL) {
						if (p->next[i] != NULL) {
							cur->next[i]->fail = p->next[i];
							break;
						}
						else
							p = p->fail;
					}
					if (p == NULL)
						cur->next[i]->fail = root;
				}
				q.push(cur->next[i]);
			}
		}
	}
}

int query(char* text) {
	// 与kmp类似
	node* cur = root;
	int position;
	int count = 0;
	int length = strlen(text);
	for (unsigned i = 0; i < length; i++) {
		position = text[i] - 'a';
		// 找到第一个匹配的
		while (cur->next[position] == NULL && cur != root)
			cur = cur->fail;
		cur = cur->next[position];
		if (cur == NULL)
			cur = root;
		node* temp = cur;
		// 将当前子串的所有后缀全部遍历一遍,直到root
		while (temp != root) {
			// 如果是只需要查看模式串出现的种类,可以加一个标记,如果再次访问到则可以不计算
			// 一般情况下就不需要改动,统计的是模式串出现的个数
			if (temp->cnt != -1) {
				count += temp->cnt;
				temp->cnt = -1;
			}
			temp = temp->fail;
		}
	}
	return count;
}

int main() {
	//freopen("1.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while (t--) {
		int n;
		scanf("%d", &n);
		init();
		for (int i = 0; i < n; i++) {
			scanf("%s", &str);
			insert(str);
		}
		build();
		scanf("%s", &str);
		printf("%d\n", query(str));
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值