poj3468 A Simple Problem with Integers[线段树成段更新成段查询]

<a target=_blank target="_blank" href="http://poj.org/problem?id=3468">poj3468 A Simple Problem with Integers[线段树成段更新成段查询]</a>


A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 87331 Accepted: 27108
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... ,AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

一道简单的线段树成段更新成段查询。
这里要用到延迟更新也即upchild()否则会超时。还有注意longlong否则会wa

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<vector>
using namespace std;
#define ll long long
const int INF=0x3f3f3f3f;
const int MAXX=100000+5;

ll sum[MAXX*4+5],mark[MAXX*4+5];

void buildTree(int o,ll left,ll right){
    mark[o]=0;
    if(left==right){
        scanf("%lld",&sum[o]);
        return;
    }
    ll mid=(left+right)>>1;
    buildTree(o<<1,left,mid);
    buildTree(o<<1|1,mid+1,right);
    sum[o]=sum[o<<1]+sum[o<<1|1];
}

void upchild(ll o,ll len){
    if(mark[o]!=0){  //表示该区间更新了但是孩子没更新
        mark[o<<1]+=mark[o];
        mark[o<<1|1]+=mark[o];
        sum[o<<1]+=(len-(len>>1))*mark[o];
        sum[o<<1|1]+=(len>>1)*mark[o];
        mark[o]=0;
    }
}
void update(ll l,ll r,ll data,ll o,ll left,ll right){
    if(l<=left && right<=r){
        sum[o]+=(right-left+1)*data;
        mark[o]+=data;
        return;
    }
    upchild(o,right-left+1);
    ll mid=(left+right)>>1;
    if(l<=mid)
        update(l,r,data,o<<1,left,mid);
    if(r>mid)
        update(l,r,data,o<<1|1,mid+1,right);
    sum[o]=sum[o<<1]+sum[o<<1|1];
}

ll query(ll l,ll r,ll o,ll left,ll right){
    if(l<=left && right<=r){
        return sum[o];
    }
    upchild(o,right-left+1);
    ll mid=(left+right)>>1;
    ll ans=0;
    if(l<=mid)
        ans+=query(l,r,o<<1,left,mid);
    if(mid<r)
        ans+=query(l,r,o<<1|1,mid+1,right);
    return ans;
}

int main(){
    ll n,m;
    while(scanf("%lld%lld",&n,&m)!=EOF){
        buildTree(1,1,n);
        char c[3];  //不要用单字符,否则得处理回车
        ll a,b,d;
        while(m--){
            scanf("%s",c);
            if(c[0]=='C'){
                scanf("%lld%lld%lld",&a,&b,&d);
                update(a,b,d,1,1,n);
            } else{
                scanf("%lld%lld",&a,&b);
                printf("%lld\n",query(a,b,1,1,n));
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值