hdu 5777 domino (贪心)


domino

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 352    Accepted Submission(s): 190


Problem Description
Little White plays a game.There are n pieces of dominoes on the table in a row. He can choose a domino which hasn't fall down for at most k times, let it fall to the left or right. When a domino is toppled, it will knock down the erect domino. On the assumption that all of the tiles are fallen in the end, he can set the height of all dominoes, but he wants to minimize the sum of all dominoes height. The height of every domino is an integer and at least 1.
 

Input
The first line of input is an integer T ( 1T10 )
There are two lines of each test case.
The first line has two integer n and k, respectively domino number and the number of opportunities.( 2k,n100000 )
The second line has n - 1 integers, the distance of adjacent domino d, 1d100000
 

Output
For each testcase, output of a line, the smallest sum of all dominoes height
 

Sample Input
  
  
1 4 2 2 3 4
 

Sample Output
  
  
9
 

Source
解题思路:要让多米诺骨牌的总高度最小,就利用k次出手的机会,避免掉k-1个最大距离,所以只用排个序,选一下前n-k个数,注意最后答案用longlong存一下就好了~

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int a[100005];
typedef long long ll;
int main()
{
    int t,n,k,i;
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        ll sum = 0;
        for(i=0;i<n-1;i++)
        {
            cin>>a[i];
        }
        sort(a,a+n-1);
        for(i=0;i<n-k;i++)
            sum += a[i];
        sum += n;
        cout << sum << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值