问题 B: Problem E

题目描述

请写一个程序,判断给定表达式中的括号是否匹配,表达式中的合法括号为”(“, “)”, “[", "]“, “{“, ”}”,这三个括号可以按照任意的次序嵌套使用。

输入

有多个表达式,输入数据的第一行是表达式的数目,每个表达式占一行。

输出

对每个表达式,若其中的括号是匹配的,则输出”yes”,否则输出”no”。

样例输入

4
[(d+f)*{}]
[(2+3))
()}
[4(6]7)9

样例输出

yes
no
no
no

算法:

使用栈

#include<bits/stdc++.h>
using namespace std;
int main()
{
   int n;
   while(cin >> n)
   {
       while(n--)
       {
           string str;
           cin >> str;
           stack<char>s;
           for(int i = 0; i<str.size(); i++)
           {
               if( str[i] == '{' || str[i] == '}' || str[i] == '[' || str[i] == ']' || str[i] == '(' || str[i] == ')')
                {
                    if(s.empty())
                   {
                       s.push(str[i]);
                   }
                   else if(str[i] == '}' && s.top() == '{')
                    {
                        s.pop();
                    }
                    else if(str[i] == ']' && s.top() == '[')
                    {
                        s.pop();
                    }
                    else if(str[i] == ')' && s.top() == '(')
                    {
                        s.pop();
                    }
                    else
                        s.push(str[i]);
                }
                else
                    continue;

           }
           cout << (s.empty() ? "yes" : "no") << endl;
       }

   }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值