7-28 单词替换 (20 分)

7-28 单词替换 (20 分)

设计一个对字符串中的单词查找替换方法,实现对英文字符串中所有待替换单词的查找与替换。

输入格式:

首行输入母字符串,第二行输入查询的单词,第三行输入替换后的单词。

输出格式:

完成查找替换后的完整字符串

输入样例:

在这里给出一组输入。例如:

Although I am without you, I will always be ou you
ou
with

输出样例:

在这里给出相应的输出。例如:

Although I am without you, I will always be with you

参考答案

import java.util.*;

class Main{
    public static void main(String[] args) {
       Scanner cin = new Scanner(System.in);
       String str_book = cin.nextLine();
       String str_old = cin.next();
       String str_new = cin.next();

       String []book_str = str_book.split(" ");

       for( int i = 0; i < book_str.length; i ++ ){
           String str = book_str[i];
           if( str.equals(str_old) || str.equals(str_old + ",") || str.equals(str_old + ".") || str.equals(str_old + "'")){
               if(! (str.charAt(str.length() - 1) >= 65 && str.charAt(str.length() - 1) <= 122) ){
                   str = str_new + str.charAt(str.length() - 1);

               }
               else{
                   str = str_new ;
               }

           }
           if( i != book_str.length - 1){
               System.out.print(str + " ");
           }
           else{
               System.out.println(str);
           }
       }

        cin.close();
    }
}
  • 3
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Hello Spring

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值