九度OJ 1042 Coincidence (动态规划求最长公共子序列)

题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:1689

解决:898

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2

求两串的最长公共子序列,算导上的动态规划例子:

#include<stdio.h>
#include<string.h>
char a[101];
char b[101];
int c[101][101];
int i,j;
void lcs(){
    int ans=0;
    int m=strlen(a);
    int n=strlen(b);
    memset(c,0,sizeof(c));
    for(i=0;i<m;++i)
        c[i][0]=0;
    for(i=0;i<n;++i)
        c[0][i]=0;
    for(i=1;i<=m;++i)
        for(j=1;j<=n;++j)
        {
            if(a[i-1]==b[j-1])
            {
                c[i][j]=c[i-1][j-1]+1;
            }
            else if(c[i-1][j]>=c[i][j-1]){
                c[i][j]=c[i-1][j];
            }
            else
            {
                c[i][j]=c[i][j-1];
            }
        }
    printf("%d\n",c[m][n]);
}
int main(int argc, char *argv[])
{
    while(~scanf("%s%s",a,b))
    {
        lcs();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值