POJ 1751 Highways


The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.
Sample Input
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3


题意:有1-N个城市,它们的坐标是(xi,yi),每一条公路连接两座城市,公路的长度是城镇之间的直线长度,公路是双向的。输入n,代表城镇个数,然后输入n个城市的坐标。输入m,接下来的m行,表示已经连接的两个城市。求出 将所有城市连接,需要建造的公路所连接的城市。


用二维数组mp存储城市之间的直线距离

例: A  (x1,y1)  -> B(x2,y2)

直线距离:d=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));

mp[A][B]=d;

然后用prim算法,求最小生成树,而在prim函数中求城市之间的最小权值时,用vis[ ]数组标记 使当前城市B到源点距离最小的城市A,用dis[ ]数组标记各城市距离源点的距离。

先更新vis[] 的值,使它们都为源点A,然后求出距离源点最近的城市B

若mp[A][B]不等于0,输出城市A和城市B的编号。

if (mp[vis[A]][B] )

  printf("%d %d\n",A,B);

然后各点是否能通过B点距离源点更近,若可以,更新dis[ i ]的值,并且更新vis[ i ]的值为B。

即 if( dis[i] >mp[B][i])

        {

            dis[i]=mp[B][i];

            vis[i]=B;

         } 


#include<math.h>
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f

int n;
float mp[1010][1010];
struct note
{
    int a;
    int b;
} que[1010];

void prim()
{
    float dis[1010],minn,sum=0;
    int t=1,v,book[1010]= {0};
    int vis[1010];

    for(int i=1; i<=n; i++)
    {
        dis[i]=mp[1][i];
        vis[i]=1;
    }
    book[1]=1;
    dis[1]=0;

    while(t<n)
    {
        minn=INF;
        for(int i=1; i<=n; i++)
        {
            if(!book[i] && dis[i]<minn)
            {
                minn=dis[i];
                v=i;
            }
        }

        book[v]=1;
        t++;
        if(mp[vis[v]][v])
            printf("%d %d\n",vis[v],v);

        for(int i=1; i<=n; i++)
        {
            if(!book[i] && dis[i]>mp[v][i])
            {
                dis[i]=mp[v][i];
                vis[i]=v;
            }
        }
    }
    return ;
}

int main()
{
    while(~scanf("%d",&n))
    {
        float d;
        int m,x,y;
        for(int i=1; i<=n; i++)
            scanf("%d%d",&que[i].a,&que[i].b);

        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(i==j)
                    mp[i][j]=0;
                else
                    mp[i][j]=INF;
            }

        for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
            {
                d=sqrt((que[i].a-que[j].a)*(que[i].a-que[j].a)+(que[i].b-que[j].b)*(que[i].b-que[j].b));
                mp[i][j]=mp[j][i]=d;
            }

        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            mp[x][y]=mp[y][x]=0;
        }
        prim();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值