Elven Postman HDU - 5444


Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.


So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.




Input
First you are given an integer T(T≤10)T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000)n(n≤1000) on a line representing the number of rooms in this tree. nn integers representing the sequence written at the root follow, respectively a1,...,ana1,...,an where a1,...,an∈{1,...,n}a1,...,an∈{1,...,n}.

On the next line, there is a number qq representing the number of mails to be sent. After that, there will be qq integers x1,...,xqx1,...,xq indicating the destination room number of each mail.
Output
For each query, output a sequence of move (EE or WW) the postman needs to make to deliver the mail. For that EE means that the postman should move up the eastern branch and WW the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
Sample Input
2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1
Sample Output
E

WE

EEEEE


题意:有t组数据

每组数据输入n,接着是n个数值,这n个数值组成一棵树,第一个表示树的根节点。

输入m,接下来是m个数值,表示要到的节点,每一次都从根节点出发。

eg: 4

2 1 4 3

3

1 2 3

则先从根节点2到1号房间,然后从根节点2出发到2号房间,最后从根节点2到3号房间。


由上面给出的图可以看出,上面的树是上下左右颠倒的,所以往左边的房间走是E,往后边的房间走是W。

解题思路: 由给出的n个数先建立一颗树,然后遍历接下来的m个房间

在每组数据结束之后释放空间,即下面程序中的removetree()函数。


#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;

struct node
{
    int val;
    node *left;
    node *right;
    node():left(NULL),right(NULL) {}
};
vector<int>res;

node * build(node * p,int v)
{
    if(p==NULL)
    {
        p=new node();  //创建新节点
        p->val=v;
        return p;
    }

    if(v > p -> val)
        p->right=build(p ->right,v);  //往右子树走
    else
        p->left=build(p ->left,v);

    return p;
}

void comp(node * p,vector<int> &res,int v)
{
    if(p->val == v)
        return ;
    if(p->val < v)
    {
        res.push_back(1);   //这里可以直接输出 eg:printf("W");
        comp(p->right,res,v);
    }
    else
    {
        res.push_back(2);  //printf("E");
        comp(p->left,res,v);
    }
    return ;
}

void removetree(node * p)
{
    if(p==NULL)
        return ;
    removetree(p->left);
    removetree(p->right);
    delete(p);
}

int main()
{
    int t,n,v,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        node * root = new node();
        scanf("%d",&v);
        root->val=v;
        for(int i=1; i<n; i++)
        {
            scanf("%d",&v);
            root=build(root,v);
        }

        scanf("%d",&m);
        while(m--)
        {
            res.clear();  //如果用vector存储路径,在每次使用前一定要清空
            scanf("%d",&v);
            comp(root,res,v);

            for(int i=0; i<res.size(); i++)
            {
                if(res[i]==1)
                    printf("W");
                else if(res[i]==2)
                    printf("E");
            }
            printf("\n");
        }
        removetree(root);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值