HDU 3280 Cheapest Palindrome

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input
Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800
Sample Output
900
Hint
If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.


假设有【1,2】(a,b),【2,3】(b,c)区间,加入区间【1,2】是不同的字符串,eg:ab,那么有两种情况 1.去掉a或者b,2.加上a或者b变成aba 或者bab 对于区间【2,3】同理。

那么同理对于区间【1,3】的情况有:1.ac 2.bc 3.aba 4.cabac 5.bab 6.cbabc 7.bc(考虑的是区间【2,3】的情况) 8.cc 9.bcb

10.cbcbc 11.cbc 12.ccbcc

故只要用一个数组存储每个字符删除或添加的最小花费即可。

不用考虑最后变成怎样的回文字符串,只要变成回文字符串即可,每个字符加上和删去效果是一样的

对于区间【i,j】,若s[i]!=s[j] 则有min(dp[i+1][j]+cost[s[i]-'a'],dp[i][j-1]+cost[s[j]-'a'])的情况

否则dp[i][j]=dp[i+1][j-1]

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char str[10010],s[2];
int n,m,cost[30],dp[2001][2001];
int a,b;

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        scanf("%s",str);
        memset(dp,0,sizeof(dp));
        for(int j=0; j<n; j++)
        {
            scanf("%s%d%d",s,&a,&b);
            cost[s[0]-'a']=min(a,b);
        }

        for(int i=1; i<m; i++)
        {
            for(int j=i-1; j>=0; j--)
            {
                if(str[i]!=str[j])
                    dp[i][j]=min(dp[i-1][j]+cost[str[i]-'a'],dp[i][j+1]+cost[str[j]-'a']);
                else dp[i][j]=dp[i-1][j+1];
            }
        }
        printf("%d\n",dp[m-1][0]);
    }
    return 0;
}

2.

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char str[10010],s[2];
int n,m,cost[30],dp[2001][2001];
int a,b;

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        scanf("%s",str);
        memset(dp,0,sizeof(dp));
        for(int j=0; j<n; j++)
        {
            scanf("%s%d%d",s,&a,&b);
            cost[s[0]-'a']=min(a,b);
        }

        for(int j=1; j<m; j++)
        {
            for(int i=j-1; i>=0; i--)
            {
                if(str[i]!=str[j])
                    dp[i][j]=min(dp[i+1][j]+cost[str[i]-'a'],dp[i][j-1]+cost[str[j]-'a']);
                else dp[i][j]=dp[i+1][j-1];
            }
        }
        printf("%d\n",dp[0][m-1]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值