B - Blocks

 

 

B - Blocks

 

 

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent

boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and

each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both

the number of red blocks and green blocks to be even numbers. Under such conditions, Panda

wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

 

#include <string.h>
#include <algorithm>
#define MOD 10007
#include <iostream>
using namespace std;

struct matrix
{
	long long m[3][3];
}a, b;

matrix multi(matrix a, matrix b)
{
	matrix c;
	memset(c.m, 0, sizeof(c.m));
	for (int i = 0; i<3; i++)
		for (int j = 0; j<3; j++)
		{
			for (int k = 0; k<3; k++)
			{
				c.m[i][j] = (c.m[i][j] + a.m[i][k] * b.m[k][j]) % MOD;
			}
		}
	return c;
}

void solve(int n)
{
	a.m[0][0] = 2; a.m[0][1] = 1; a.m[0][2] = 0;
	a.m[1][0] = 2; a.m[1][1] = 2; a.m[1][2] = 2;
	a.m[2][0] = 0; a.m[2][1] = 1; a.m[2][2] = 2;
	memset(b.m, 0, sizeof(b.m));
	b.m[0][0] = b.m[1][1] = 1; b.m[2][2] = 1;
	while (n)
	{
		if (n & 1)
			b = multi(b, a);
		a = multi(a, a);
		n >>= 1;
	}
}



int main()
{
	int T, N;
	cin >> T;
	while (T--)
	{
		cin >> N;
		solve(N);
		long long ans = (b.m[0][0] % MOD);
		cout << ans<<endl;
	}
	system("pause");
	return 0;
}

 

 

此题见于《挑战城与设计》P202,POJ3734,解决方法是依据题意推出递推,转化为矩阵幂的求解。

另外本题采用的是定长的二维数组,求解起来也非常简单。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值