动态规划hdu Max Sum

Max Sum

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 15   Accepted Submission(s) : 4
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
最大自子序列和,没用用到动态规划的根本知识,单纯的累加判断而已,如果有大神到来请多指教,
#include<iostream> using namespace std; int main() {  int t,i,j,n,max,st,la,s,x,l;  cin>>t;  for(i=1;i<=t;i++)  {   cin>>n;   max=-1001;   s=0;   l=0;   for(j=1;j<=n;j++)   {    cin>>x;    s+=x;    l++;    if(s>max)    {     max=s;     la=j;     st=j-l+1;    }    if(s<0)    {     l=0;  //这地方改了下,就AC了。     s=0;    }   }   cout<<"Case "<<i<<":"<<endl;   cout<<max<<" "<<st<<" "<<la<<endl;   if(i!=t)    cout<<endl;  }  return 0; }
动态规划实现的代码如下
#include<iostream>
#include <cstdio>
#define N 100010
using namespace std;
int a[N],b[N];
int main()
{
    int t,n;
    scanf("%d",&t);
    int k=1;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        b[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            if(b[i-1]<0)
                b[i]=a[i];
            else
                b[i]=a[i]+b[i-1];
        }
        int max=b[1];
        int e=1;
        for(int i=2;i<=n;i++)
        {
            if(max<b[i])
            {
                 max=b[i];
                e=i;
            }
        }
        int test=0;
        int f=e;
        for(int i=e;i>0;i--)
        {
            test+=a[i];
            if(test==max)
                f=i;
        }
        cout<<"Case "<<k++<<":"<<endl<<max<<" "<<f<<" "<<e<<endl;
        if(t) cout<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ink__Bamboo

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值