数据结构实验之二叉树四:(先序中序)还原二叉树
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description
给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。
Input
输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。
Output
输出一个整数,即该二叉树的高度。
Example Input
9
ABDFGHIEC
FDHGIBEAC
Example Output
5
Hint
Author
xam
#include <iostream>
#include <cstdio>
using namespace std;
typedef struct node
{
char data;
struct node *lc, *rc;
} bt, *pbt;
const int MAX = 55;
char stra[MAX];
char strb[MAX];
pbt pre_midorder(int n, char a[], char b[])
{
if (n == 0)
return NULL;
char *p;
for (p = b; p != '\0'; p++)
{
if (*p == a[0])
break;
}
int lenleftroot = p - b;//当前节点左孩子树元素个数
pbt root = new bt;
root->data = a[0];
root->lc = pre_midorder(lenleftroot, a + 1, b);
root->rc = pre_midorder(n - lenleftroot - 1, a + lenleftroot + 1, p + 1);//a + lenleftroot + 1是当前节点右子树的树根
return root;
}
int deep(pbt root)
{
if (root == NULL)
{
return 0;
}
int dp = 0;
int dl = deep(root->lc);
int dr = deep(root->rc);
dp = dl > dr ? dl + 1 : dr + 1;
return dp;
}
int main()
{
int n;
while(~scanf("%d", &n))
{
scanf("%s", stra);
scanf("%s", strb);
pbt root;
root = NULL;
root = pre_midorder(n, stra, strb);
int ct = deep(root);
printf("%d\n", ct);
}
}