C语言实验——最小公倍数和最大公约数

C语言实验——最小公倍数和最大公约数
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
从键盘输入两个正整数,求这两个正整数的最小公倍数和最大公约数,并输出。
Input
输入包括一行。
两个以空格分开的正整数。
Output
两个整数的最小公倍数和最大公约数。
Sample Input
6 8
Sample Output
24 2
Hint

Source



import java.util.*;

class Main {
    public static void main(String[] args) {

        Scanner ss = new Scanner(System.in);
        int n, m;
        int a, b;
        n = ss.nextInt();
        m = ss.nextInt();
        a = n; 
        b = m;
        int t;
        if(n < m) {
            t = n;
            n = m;
            m = t;
        }
        while(m > 0) {
            t = n % m;
            n = m;
            m = t;
        }
        System.out.printf("%d %d\n", a * b / n, n);
        ss.close();
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值