L1-039 古风排版(20 分)
中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。
输入格式:
输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。
输出格式:
按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)
输入样例:
4
This is a test case
输出样例:
asa T
st ih
e tsi
ce s
用Java写
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
sc.nextLine();
char[] s = sc.nextLine().toCharArray();
int l; // l用来表示列数-1,-1是为了方便下面使用
if (s.length % n == 0)
l = s.length / n - 1;
else
l = s.length / n;
for (int i = 0; i < n; i++) {
for (int j = l