HDU - 1002-A + B Problem II (大数加法)

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题解:模拟加法,加进位之间的关系即可

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int main () {
	char a[8000],b[8000];
	int na[8000],nb[8000],sum[8000],pre,flag=1;
	int t;
	scanf("%d",&t);
	while (t--) {
		memset(sum,0,sizeof(sum));
		memset(na,0,sizeof(na));
		memset(nb,0,sizeof(nb));
		scanf("%s%s",a,b);
		pre=0;
		int lena=strlen(a);
		int lenb=strlen(b);
		for (int i=0; i<lena; i++)
			na[lena-1-i]=a[i]-'0';
		for (int j=0; j<lenb; j++)
			nb[lenb-1-j]=b[j]-'0';
		int lenx=lena>lenb?lena:lenb;
		for (int k=0; k<lenx; k++) {
			sum[k]=na[k]+nb[k]+pre/10;
			pre=sum[k];
		}
		while (pre>9) {
			sum[lenx]=pre/10%10;
			lenx++;
			pre/=10;
		}
		printf ("Case %d:\n",flag++);
		printf ("%s + %s = ",a,b);
		for (int i=lenx-1; i>=0; i--) {
			printf ("%d",sum[i]%10);
		}
		printf ("\n");
		if (t)
			printf ("\n");
	}

	return 0;
}

 

转载于:https://www.cnblogs.com/Staceyacm/p/10782005.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值