A + B Problem II (HDU - 1002 )

A + B Problem II (HDU - 1002 )

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题目翻译:

我有一个非常简单的问题要问你。给定两个整数A和B,你的工作是计算A + B的和。

输入

输入的第一行包含一个整数T(1<=T<=20),它表示测试用例的数量。然后是T行,每一行由两个正整数组成,A和b。注意,这些整数非常大,这意味着不应该使用32位整数来处理它们。您可以假设每个整数的长度不超过1000。

输出

对于每个测试用例,您应该输出两行。第一行是“Case #:”,#表示测试用例的数量。第二行是一个方程“A + B = Sum”,Sum表示A + B的结果。在两个测试用例之间输出空行。

思路:大数模板题

AC代码:
 

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
char s1[10010],s2[10010];
int a[10010],b[10010],c[10010];
int main()
{
    int t;
    int k=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        scanf("%s %s",s1, s2);
        int l1=strlen(s1);
        int l2=strlen(s2);
        int j=0;
        for(int i=l1-1; i>=0; i--)
            a[j++]=s1[i]-'0';
        j=0;
        for(int i=l2-1; i>=0; i--)
            b[j++]=s2[i]-'0';
        int l3=l1>l2?l1:l2;
        int p=0;
        int r=0;
        for(int i=0; i<l3; i++)
        {
            p=a[i]+b[i]+r;
            r=p/10;
            c[i]=p%10;
        }
        if(r)
            c[l3++]++;
        while(l3>1 && c[l3-1]==0)
        {
            l3--;
        }
        printf("Case %d:\n",k++);
        printf("%s + ",s1);
        printf("%s = ",s2);
        for(int i=l3-1; i>=0; i--)
            printf("%d",c[i]);
            printf("\n");
        if(t)
            printf("\n");
    }
    return 0;
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值