HDU2819(二分图匹配,记录过程)

Swap

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2236    Accepted Submission(s): 801
Special Judge


Problem Description
Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
 
Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
 
Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”. 
 
Sample Input
2
0 1
1 0
2
1 0
1 0
 
Sample Output
1
R 1 2
-1
 
Source
 
很好的一道题,值得深思。
题意:可交换任意两行或任意两列,最终是主对角线上全为1,输出交换过程
如果可行的话,一定可以只交换列或只交换行得到,因为不管怎么交换,原先在同一行的始终在同一行,原先在同一列的始终在同一列。想到这,构图也就出来了,对行和列构图,如果mp[i][j]==1则在i和j之间加边
/*
ID: LinKArftc
PROG: 2819.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

const int maxn = 110;

int mp[maxn][maxn];
int linker[maxn];
bool vis[maxn];
int n;

bool dfs(int u) {
    for (int v = 1; v <= n; v ++) {
        if (!vis[v] && mp[u][v]) {
            vis[v] = true;
            if (linker[v] == -1 || dfs(linker[v])) {
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungry() {
    memset(linker, -1, sizeof(linker));
    int ret = 0;
    for (int i = 1; i <= n; i ++) {
        memset(vis, 0, sizeof(vis));
        if (dfs(i)) ret ++;
    }
    return ret;
}

int a[maxn], b[maxn];

int main() {
    //input;
    while (~scanf("%d", &n)) {
        int tmp;
        memset(mp, 0, sizeof(mp));
        for (int i = 1; i <= n; i ++) {
            for (int j = 1; j <= n; j ++) {
                scanf("%d", &tmp);
                if (tmp) mp[i][j] = 1;
            }
        }
        int ans = hungry();
        if (ans < n) printf("-1\n");
        else {
            int cnt = 0;
            for (int i = 1; i <= n; i ++) {
                int j;
                for (j = i; j <= n; j ++) {
                    if (linker[j] == i) break;
                }
                if (j != i) {
                    cnt ++;
                    a[cnt] = i; b[cnt] = j;
                    swap(linker[i], linker[j]);
                }
            }
            printf("%d\n", cnt);
            for (int i = 1; i <= cnt; i ++) printf("C %d %d\n", a[i], b[i]);
        }
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/LinKArftc/p/4908965.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值