【贪心】[hdu1052]Tian Ji -- The Horse Racing(田忌赛马)[c++]

                                                   Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Here is a famous story in Chinese history.
“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”
“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”
“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”
“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”
“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”
Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…
However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.
In this problem, you are asked to write a program to solve this special case of matching problem.

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output
200
0
0

Source
2004 Asia Regional Shanghai

原题链接

贪心策略

先对田忌、齐王的马按照速度分别排序。
对排序后的两组马的速度,按如下规则比较:

一、当前田忌最慢的马比齐王最慢的马要快,因为田忌任何马都能赢齐王的这匹最慢的马,就拿自己最慢的马来和齐王比,赢一局且实力损失最小。

二、当前田忌最慢的马比齐王最慢的马要慢,因为田忌最慢的马一定会输齐王任何的马,就拿这匹马和齐王最快的马比,输一局且消耗的齐王实力最大。

三、当前田忌最快的马比齐王最快的马要慢,因为田忌任何马都会输给齐王的这匹最快的马,就拿自己最慢的马来和齐王比,输一局且实力损失最小。

四、当前田忌最快的马比齐王最快的马要快,因为田忌最快的马和齐王的任何马比都会赢,就那这匹马和齐王最快的马比,赢一局且消耗的齐王实力最大。

一二和三四的比较顺序无所谓

五、头尾都相等时,用田忌最慢的马消耗齐王最快的马,出现两种情况:
- 1.齐王最快的马比田忌最慢的马快,输一局。
- 2.齐王最快的马与田忌最慢的马相等,平一局,此时所有马的速度都相等。

代码[c++]
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int HOUSEN = 1005;
int main()
{
    int n;
    while(scanf("%d",&n)&&n!=0)
    {
        int tian[HOUSEN],king[HOUSEN];
        for(int i=0; i<n; i++)
            scanf("%d",tian+i);
        for(int i=0; i<n; i++)
            scanf("%d",king+i);
        sort(tian,tian+n);
        sort(king,king+n);
        int tleft=0,tright=n-1;
        int kleft=0,kright=n-1;
        int win=0,lost=0;
        while(tleft<=tright)
        {
            if(tian[tleft]>king[kleft])
            {
                win++;
                tleft++;
                kleft++;
            }
            else if(tian[tleft]<king[kleft])
            {
                lost++;
                tleft++;
                kright--;
            }
            else if(tian[tright]<king[kright])
            {
                lost++;
                tleft++;
                kright--;
            }
            else if(tian[tright]>king[kright])
            {
                win++;
                tright--;
                kright--;
            }
            else
            {
                if(tian[tleft]<king[kright])lost++;
                tleft++;
                kright--;
            }
        }
        printf("%d\n",200*(win-lost));
    }
    return 0;
}

转载于:https://www.cnblogs.com/NeilThang/p/9356635.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值