poj2230(欧拉回路模板)

Watchcow
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 6887 Accepted: 3004 Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...

题意:给出一个图,让你求欧拉回路,不过这题每条边可以走两遍,不过这两遍不能同方向。


思路:dfs,用vis数组来记录是否走过该点的状态。


在这里贴个求欧拉回路的模板:

int ans[maxn];///maxn是边的最大数量
bool vis[maxn];
int bj;
void dfs(int now)
{
    for(int i=head[now];i!=-1;i=tu[i].next)
    if(!vis[i])
    {
        vis[i]=1;
        vis[i^1]=1;///这里是求欧拉回路,这一题用不着写这句,因为可以走双向
        dfs(tu[i].to);
        ans[bj++]=i;///等于i是记录边,等于tu[i].to是记录点
    }
}

下面是ac代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iomanip>
using namespace std;
typedef long long ll;
const int N=10005,maxn=50010;
int head[N];
int ip;
struct edgenode
{
    int to;
    int next;
} tu[N*N];
void init()
{
    ip=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    tu[ip].to=v,tu[ip].next=head[u],head[u]=ip++;
}

int ans[maxn];
bool vis[maxn];
int bj;
void dfs(int now)
{
    for(int i=head[now]; i!=-1; i=tu[i].next)
        if(!vis[i])
        {
            vis[i]=1;
            //vis[i^1]=1;
            dfs(tu[i].to);
            ans[bj++]=tu[i].to;
        }
}

int main()
{
    int m,n;
    scanf("%d%d",&n,&m);
    init();
    while(m--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        add(a,b);
        add(b,a);
    }
    memset(vis,0,sizeof(vis));
    memset(ans,0,sizeof(ans));
    bj=0;
    dfs(1);
    for(int i=0; i<bj; i++)
        cout<<ans[i]<<endl;
    cout<<1<<endl;
}


转载于:https://www.cnblogs.com/martinue/p/5490413.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值