poj水题--ID3062

Problem:

Description

It's hard to construct a problem that's so easy that everyone will get it, yet still difficult enough to be worthy of some respect. Usually, we err on one side or the other. How simple can a problem really be? 

Here, as in Celebrity Jepoardy, questions and answers are a bit confused, and, because the participants are elebrities, there’s a real need to make the challenges simple. Your program needs to prepare a question to be solved --- an equation to be solved --- given the answer. Specifically, you have to write a program which finds the simplest possible equation to be solved given the answer, considering all possible equations using the standard mathematical symbols in the usual manner. In this context, simplest can be defined unambiguously several different ways leading to the same path of resolution. For now, find the equation whose transformation into the desired answer requires the least effort. 

For example, given the answer X = 2, you might create the equation 9 - X = 7. Alternately, you could build the system X > 0; X^2 = 4. These may not be the simplest possible equations. Solving these mind-scratchers might be hard for a celebrity.

Input

Each input line contains a solution in the form <symbol> = <value>

Output

For each input line, print the simplest system of equations which would to lead to the provided solution, respecting the use of space exactly as in the input.

Sample Input

Y = 3
X=9

Sample Output

Y = 3
X=9


我的submission:(人品爆好,都是一次性通过,Time:O MS)
#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s;
    int i=10;
    while(i>0)
    {getline(cin,s);
    cout<<s<<endl;
    i--;}
    return 0;
    
    }

 其实感觉ACM这个平台,还是有很多地方可以偷懒的。比如这个题,大家看我的程序也可以晓得,其实没有达到它题目的真正要求。或者说本来题目就是有点绕,其实目的就是读入一个equation,接着输出这个equation就OK。总之这个题是讲的有点糊涂,但是其实超级水。

稍微改进了一下代码:

#include<iostream>
#include<string>
using namespace std;
int main()
{
    string s;
    string temp;
    while(cin>>temp)
    {getline(cin,s);
    s=temp+s;
    cout<<s<<endl;}
    return 0;
    
    }

转载于:https://www.cnblogs.com/lx09110718/archive/2012/10/10/poj3062.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值