poj 3734 Blocks

http://poj.org/problem?id=3734

Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4626 Accepted: 2102

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6
红绿都是偶数的方案为ai,红绿恰有一个偶数的方案为bi,红绿都是奇数的方案为ci
ai+1=2*ai+bi;
bi+1=2*ai+2*bi+2*ci;
ci+1=bi+2*ci;
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
typedef vector<int> vec;
typedef vector<vec> mat;
typedef long long ll;
const int M=10007;
int N;
mat mul( mat &A,mat &B)
{

    mat C(A.size(),vec(B[0].size()));
     for(int i=0;i<A.size();i++)
     {
      for(int k=0;k<B.size();k++)
      {
        for(int j=0;j<B[0].size();j++)
        {
            C[i][j]=(C[i][j]+A[i][k]*B[k][j])%M;
        }
      }

     }
     return C;
}
mat pow(mat A,ll n)
{
    mat B(A.size(),vec(A.size()));
     for(int i=0;i<A.size();i++)
    {
        B[i][i]=1;
    }
    while(n>0)
    {
        if(n&1)
        B=mul(B,A);
        A=mul(A,A);
        n>>=1;
    }
    return B;
}
void solve()
{
    mat A(3,vec(3));
    A[0][0]=2;A[0][1]=1;A[0][2]=0;
    A[1][0]=2;A[1][1]=2;A[1][2]=2;
    A[2][0]=0;A[2][1]=1;A[2][2]=2;
    A=pow(A,N);
    printf("%d\n",A[0][0]);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
    scanf("%d",&N);
    solve();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/cancangood/p/4550103.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值