poj3734(矩阵快速幂)

Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7108 Accepted: 3440

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6

Ai代表两个同时为偶数方案数,Bi表示两个中某一个为偶数方案数,Ci表示两个都为奇数方案数。

则有矩阵递推式:

Ai+1 2 1 0 Ai

Bi+1 = 2 2 2 Bi

Ci+1 0 1 2 Ci


#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
//用二维vector来表示矩阵 
typedef vector<int> vec;
typedef vector<vec> mat;
typedef long long ll;

const int M=10007;       //模数 
//计算A*B 
mat mul(mat &A,mat &B)
{
	mat C(A.size(),vec(B[0].size()));
	for(int i=0;i<A.size();i++)
	{
		for(int k=0;k<B.size();k++)
		{
			for(int j=0;j<B[0].size();j++)
			{
				C[i][j]=(C[i][j]+A[i][k]*B[k][j])%M;
			}
		}
	}
	return C;
}
//计算A^n 
mat pow(mat A,ll n)
{
	mat B(A.size(),vec(A.size()));
	for(int i=0;i<A.size();i++)
	{
		B[i][i]=1;
	}
	while(n>0)
	{
		if(n&1)B=mul(B,A);
		A=mul(A,A);
		n>>=1;
	}
	return B;
}
int n;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		mat A(3,vec(3));
		A[0][0]=2;
		A[0][1]=1;
		A[0][2]=0;
		A[1][0]=2;
		A[1][1]=2;
		A[1][2]=2;
		A[2][0]=0;
		A[2][1]=1;
		A[2][2]=2;
		mat B=pow(A,n);
		printf("%d\n",B[0][0]);
	}
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值