POJ 1308 Is It A Tree? 解题报告

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32052 Accepted: 10876

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997


再写一题,顺便巩固一下并查集基础,poj1182还没想好,先写了这题吧

题解:这道题的意思是判断给定的边是否构成一颗树,注意不能是森林,我这里用的并查集的方法,每次输入x,y两个点就合并x,y,但是在处理判断是否为森林时感觉处理的不好,我是逐个判断是不是有相同的父亲结点来处理的,感觉优化的不是很好,好在AC了。

#include <iostream>
#include <cstdio>
#include <vector>

const int maxn = 1e6+7;

using namespace std;

int father[maxn], n;

void init()
{
    for (int i=0; i<=maxn; i++)
        father[i] = i;
}


int fi(int x)
{
    return x == father[x] ? x : father[x] = fi(father[x]);
}

void unite(int x, int y)
{
    int p1 = fi(x), p2 = fi(y);
    if (p1 == p2) return;
    father[p1] = p2;
}

int same(int x, int y)
{
    int p1 = fi(x), p2 = fi(y);
    if (p1 == p2)
        return 1;
    return 0;
}

int main()
{
    int a, b;
    int c = 1;
    vector<int> v;
    init();bool judge = true;
    while (~scanf("%d%d", &a, &b))
    {
        if (a == -1 && b == -1) break;
        if (a == 0 && b == 0) {
            for (int i=0; i<v.size(); i++) {
                for (int j=i+1; j<v.size(); j++) {//判断是否构成森林
                    if (i != j && v[i] != v[j] && !same(v[i], v[j])) {
                        judge = false;
                        break;
                    }
                }
                if (!judge) break;
            }
            if (judge)
                printf("Case %d is a tree.\n", c);
            else
                printf("Case %d is not a tree.\n", c);
            c++;
            init();
            v.clear();
            judge = true;
        }else {
            v.push_back(a);
            v.push_back(b);
            if (!same(a, b)) //判断是否构成回路或者环
                unite(a, b);
            else {
                judge = false;
            }
        }
    }
    return 0;
}


转载于:https://www.cnblogs.com/fayne/p/7224789.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值