HUST 1606 - Naive

1606 - Naive

时间限制:3秒 内存限制:128兆
779 次提交 138 次通过
题目描述
Give you a positive integer x, determine whether it is the sum of three positive cubic numbers.
输入
There’re several test cases. For each case:
Only one line containing an integer x (1≤x≤10^6)
输出
For each test case, print “Yes” if it is or “No” if it isn’t.
(See sample for more details)
样例输入
1
3
10
样例输出
No
Yes
Yes、

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int a[100005];
int b[1000005];
int cot;
void init()
{
    cot=0;
    for(int i=1;i<=200;i++)
    {
        if(i*i*i<=1000000)
         a[cot++]=i*i*i;
        else
            break;
    }
}
void init2()
{
     int cnt=0;
          for(int i=0;i<cot;i++)
          {
              for(int j=0;j<cot;j++)
              {
                  for(int k=0;k<cot;k++)
                  {
                      if(a[i]+a[j]+a[k]<=1000000)
                     b[a[i]+a[j]+a[k]]=1;
                  }

              }

          }

}
int main()
{
    int n;
    init();

            init2();
    while(scanf("%d",&n)!=EOF)
    {

          if(b[n])
          printf("Yes\n");
          else
              printf("No\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228780.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值