HUST 1606 Naive

Description

Give you a positive integer x, determine whether it is the sum of three positive cubic numbers.

Input

There’re several test cases. For each case: 
Only one line containing an integer x (  1≤x≤10^6)

Output

For each test case, print “Yes” if it is or “No” if it isn’t. 
(See sample for more details)

Sample Input

1
3
10

Sample Output

No
Yes

Yes

判断一个数能不能是三个立方数的和,先预处理一下两个立方数的和,然后询问的时候找一个立方数就好了

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=1e6+10;
int x,f[maxn];

int main()
{
	for (int i=1;i*i*i<maxn;i++)
	{
		for (int j=i;j*j*j<maxn;j++)
		{
			if (i*i*i+j*j*j<maxn) f[i*i*i+j*j*j]=1;
		}
	}
	while (~scanf("%d",&x))
	{
		int flag=0;
		for (int i=1;i*i*i<=x;i++)
		{
			if (f[x-i*i*i]) {flag=1; break;}
		}
		printf("%s\n",flag?"Yes":"No");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值