POJ3621Sightseeing Cows

Sightseeing Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10595 Accepted: 3632

Description

Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time.

Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landmarks (conveniently numbered 1.. L) and the P (2 ≤ P ≤ 5000) unidirectional cow paths that join them. Farmer John will drive the cows to a starting landmark of their choice, from which they will walk along the cow paths to a series of other landmarks, ending back at their starting landmark where Farmer John will pick them up and take them back to the farm. Because space in the city is at a premium, the cow paths are very narrow and so travel along each cow path is only allowed in one fixed direction.

While the cows may spend as much time as they like in the city, they do tend to get bored easily. Visiting each new landmark is fun, but walking between them takes time. The cows know the exact fun values Fi (1 ≤ Fi ≤ 1000) for each landmark i.

The cows also know about the cowpaths. Cowpath i connects landmark L1i to L2i (in the direction L1i -> L2i ) and requires time Ti (1 ≤ Ti ≤ 1000) to traverse.

In order to have the best possible day off, the cows want to maximize the average fun value per unit time of their trip. Of course, the landmarks are only fun the first time they are visited; the cows may pass through the landmark more than once, but they do not perceive its fun value again. Furthermore, Farmer John is making the cows visit at least two landmarks, so that they get some exercise during their day off.

Help the cows find the maximum fun value per unit time that they can achieve.

Input

* Line 1: Two space-separated integers: L and P
* Lines 2..L+1: Line i+1 contains a single one integer: Fi
* Lines L+2..L+P+1: Line L+i+1 describes cow path i with three space-separated integers: L1i , L2i , and Ti

Output

* Line 1: A single number given to two decimal places (do not perform explicit rounding), the maximum possible average fun per unit time, or 0 if the cows cannot plan any trip at all in accordance with the above rules.

Sample Input

5 7
30
10
10
5
10
1 2 3
2 3 2
3 4 5
3 5 2
4 5 5
5 1 3
5 2 2

Sample Output

6.00

题目大意:最优比率环
求一个环的点权/边权最大
题解:01分数规划
二分的答案为ans,则任意一个环都满足
sigma vi / sigma ei <=ans,那么ans不可能再扩大。sigma vi <=ans* sigma ei,
sigma (ans*ei-vi)>=0,如果存在一个小于0的环,那么ans还可以扩大。将边权变为ans*ei-vi,
然后dfs判断负环。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1009
using namespace std;

int n,m,sumedge;
int head[maxn],v[maxn],vis[maxn];
double dis[maxn];
double l,r,mid,eps=1e-7;
struct Edge{
    int x,y,z,nxt;
    Edge(int x=0,int y=0,int z=0,int nxt=0):
        x(x),y(y),z(z),nxt(nxt){}
}edge[maxn*6];

void add(int x,int y,int z){
    edge[++sumedge]=Edge(x,y,z,head[x]);
    head[x]=sumedge;
}

bool dfs(int x,double p){
    vis[x]=true;
    for(int i=head[x];i;i=edge[i].nxt){
        int vv=edge[i].y;
        if(dis[vv]>dis[x]+p*edge[i].z-v[vv]) {
            dis[vv]=dis[x]+p*edge[i].z-v[vv];
            if(vis[vv])return true;
            else if(dfs(vv,p))return true;
        }
    }
    vis[x]=false;
    return false;
}

bool check(double p){
    for(int i=1;i<=n;i++){
        memset(vis,0,sizeof(vis));
        memset(dis,0,sizeof(dis));
        if(dfs(i,p))return true;
    }
    return false;
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)scanf("%d",&v[i]);
    for(int i=1;i<=m;i++){
        int x,y,z;
        scanf("%d%d%d",&x,&y,&z);
        add(x,y,z);
    }
    l=0.;r=1000.0;
    while(r-l>eps){
        mid=(l+r)/2.;
        if(check(mid))l=mid;
        else r=mid;
    }
    printf("%.2f\n",l);
    return 0;
}

 

 

转载于:https://www.cnblogs.com/zzyh/p/7640370.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值