usaco1.5.1(numtri)

1.4.2的题目虽然有点眉目但是编码时却始终无从下手,找了份只有36行的结题报告却看不懂,运行了下还可以,结果就干了件丑事贴人家代码了,保证下不为例。

 

题目:

Number Triangles

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

PROGRAM NAME: numtri

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

SAMPLE INPUT (file numtri.in)

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT (file numtri.out)

30


以前做杭电dp时见过很多遍,不解释直接上代码
/*
ID:614433244
PROG: numtri
LANG: C++
*/

#include"iostream"
#include"cstdio"
#include"memory.h"
using namespace std;
int a[1001][1001];
int dp[1001][1001];
int main()
{
    freopen("numtri.in","r",stdin);
    freopen("numtri.out","w",stdout);
    int i,j,n;
    scanf("%d",&n);
    for( i=0;i<n;i++ )
        for( j=0;j<=i;j++ )
            scanf("%d",&a[i][j]);
    for( i=0;i<n;i++ )
        dp[n-1][i]=a[n-1][i];
    for( i=n-2;i>=0;i-- )
    {
        for( j=0;j<=i;j++ )
            dp[i][j]=a[i][j]+max( dp[i+1][j],dp[i+1][j+1] );
    }
    printf("%d\n",dp[0][0]);
    return 0;
}

转载于:https://www.cnblogs.com/rolyxiao/archive/2012/07/17/2595480.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值