poj2914 Minimum Cut 全局最小割模板题

Minimum Cut
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 8324 Accepted: 3488
Case Time Limit: 5000MS

Description

Given an undirected graph, in which two vertices can be connected by multiple edges, what is the size of the minimum cut of the graph? i.e. how many edges must be removed at least to disconnect the graph into two subgraphs?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (2 ≤ N ≤ 500, 0 ≤ MN × (N − 1) ⁄ 2) in one line, where N is the number of vertices. Following are M lines, each line contains M integers A, B and C (0 ≤ A, B < N, AB, C > 0), meaning that there C edges connecting vertices A and B.

Output

There is only one line for each test case, which contains the size of the minimum cut of the graph. If the graph is disconnected, print 0.

Sample Input

3 3
0 1 1
1 2 1
2 0 1
4 3
0 1 1
1 2 1
2 3 1
8 14
0 1 1
0 2 1
0 3 1
1 2 1
1 3 1
2 3 1
4 5 1
4 6 1
4 7 1
5 6 1
5 7 1
6 7 1
4 0 1
7 3 1

Sample Output

2
1
2

Source

Baidu Star 2006 Semifinal
Wang, Ying (Originator)
Chen, Shixi (Test cases)
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 555
#define inf 1<<30

int v[MAXN],dist[MAXN];
int map[MAXN][MAXN];
bool vis[MAXN];
int n,m;

//求全局最小割的Stoer_Wanger算法
 int Stoer_Wanger(int n)
{
     int res=inf;
    for(int i=0;i<n;i++)v[i]=i;
    while(n>1){
        int k=0,pre=0;//pre用来表示之前加入A集合的点,我们每次都以0点为第一个加入A集合的点
        memset(vis,false,sizeof(vis));
        memset(dist,0,sizeof(dist));
        for(int i=1;i<n;i++){
            k=-1;
            for(int j=1;j<n;j++){
                if(!vis[v[j]]){
                    dist[v[j]]+=map[v[pre]][v[j]];//dis数组用来表示该点与A集合中所有点之间的边的长度之和
                    if(k==-1||dist[v[k]]<dist[v[j]]){
                        k=j;
                    }
                }
            }
            vis[v[k]]=true;
            if(i==n-1){
                res=min(res,dist[v[k]]);
                //将该点合并到pre上,相应的边权就要合并
                for(int j=0;j<n;j++){
                    map[v[pre]][v[j]]+=map[v[j]][v[k]];
                    map[v[j]][v[pre]]+=map[v[j]][v[k]];
                }
                v[k]=v[--n];//删除最后一个点
            }
            pre=k;
        }
    }
    return res;
}

int main()
{
    int u,v,w,ss;
    while(~scanf("%d%d",&n,&m)){

        memset(map,0,sizeof(map));
        while(m--){
            scanf("%d%d%d",&u,&v,&w);

            map[u][v]+=w;
            map[v][u]+=w;
        }
        int ans=Stoer_Wanger(n);
        printf("%d\n",ans);
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/13224ACMer/p/4726253.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值