hau1021 Fibonacci Again(递归)

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72329    Accepted Submission(s): 33039


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0
1
2
3
4
5
 
Sample Output
no
no
yes
no
no
no
 
//(a+b)%c=(a%c+b%c)%c;
#include<iostream>
#include<math.h>
#include<stdio.h>
using namespace std;
long long a[10000005];
int main()
{
  long long n;
  a[0]=7%3,a[1]=11%3;
  for(int i=2;i<1000005;i++)
    a[i]=(a[i-1]+a[i-2])%3;//和DP很像
  while(cin>>n)
  {
    if(a[n]==0)
      cout<<"yes"<<endl;
    else
      cout<<"no"<<endl;
  }
  return 0;

}

 

转载于:https://www.cnblogs.com/-citywall123/p/9509540.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值