hdu 1099(数学)

Lottery

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3333    Accepted Submission(s): 1489


Problem Description
Eddy's company publishes a kind of lottery.This set of lottery which are numbered 1 to n, and a set of one of each is required for a prize .With one number per lottery, how many lottery on average are required to make a complete set of n coupons?
 

 

Input
Input consists of a sequence of lines each containing a single positive integer n, 1<=n<=22, giving the size of the set of coupons.
 

 

Output
For each input line, output the average number of lottery required to collect the complete set of n coupons. If the answer is an integer number, output the number. If the answer is not integer, then output the integer part of the answer followed by a space and then by the proper fraction in the format shown below. The fractional part should be irreducible. There should be no trailing spaces in any line of ouput.
 

 

Sample Input
2 5 17
 

 

Sample Output
3 5 11 -- 12 340463 58 ------ 720720
 

 

Author
eddy
题意很难理解。。看了别人的翻译才懂。。
题目的大概意思是说一套彩票有编号1到n共n种,张数不限,问你平均买多少张能把编号为1到n的n中彩票全买下来,也就是求期望。
也就是求n/n+n/(n-1)+...+n/1..迭代求解 a/b+1/i = ai+b/(bi)
第一组测试用例后面明明有一个空格...结果加了之后还报了一次格式错误。。。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
typedef long long LL;
LL gcd(LL a,LL b){
    return b==0?a:gcd(b,a%b);
}
LL lcm(LL a,LL b){
    return a/gcd(a,b)*b;
}
int getLen(LL num){
    int ans = 0;
    while(num){
        ans++;
        num/=10;
    }
    return ans;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        LL a=1,b=1; ///a为分子,b为分母
        for(int i=2;i<=n;i++){
            a = a*i+b;
            b = b*i;
            LL d = gcd(a,b);
            a/=d;
            b/=d;
        }
        a=a*n;
        LL d = gcd(a,b);
        a/=d,b/=d;
        LL res = a/b;
        if(a%b==0){
            printf("%lld\n",a/b);
        }else {
            LL len = getLen(res);
            LL len1 = getLen(b);
            LL yushu = a%b;
            for(int i=0;i<=len;i++){
                printf(" ");
            }
            printf("%lld\n%lld ",yushu,res);
            for(int i=0;i<len1;i++) printf("-");
            printf("\n");
             for(int i=0;i<=len;i++){
                printf(" ");
            }
            printf("%lld\n",b);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/liyinggang/p/5571437.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值