PAT Advanced Level 1013 Battle Over Cities (25)(25 分)

1013 Battle Over Cities (25)(25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city~1~-city~2~ and city~1~-city~3~. Then if city~1~ is occupied by the enemy, we must have 1 highway repaired, that is the highway city~2~-city~3~.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (&lt1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

只会算法不会读题一点用都没有,小BUG浪费了我二十分钟,我是以考试的心情做的,结果并不理想,我已经预见了
九月八号我的未来,但是这并不妨碍我继续做梦?。

/**********************
author: yomi
date: 18.8.19
ps:
**********************/
#include <iostream>
#include <vector>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1010;
vector<int>g[maxn];
int no[maxn], n;
bool vis[maxn];

void dfs(int index)
{
    if(index == n+1)
        return;
    if(!vis[index]){
        vis[index] = true;
        for(int i=0; i<g[index].size(); i++){
            dfs(g[index][i]);
        }
    }
}
int main()
{
    int m, k, u, v, d, cnt = 0;
    scanf("%d%d%d", &n, &m, &k);
    for(int i=1; i<=m; i++){
        scanf("%d%d", &u, &v);
        g[u].push_back(v);
        g[v].push_back(u);
    }
    for(int i=1; i<=k; i++){
        cnt = 0;
        memset(vis, 0, sizeof(vis));
        scanf("%d", &d);
        vis[d] = true;
        for(int j=1; j<=n; j++){///BUG所在之处,原来写成了k,k只是我们关心的城市数啊。当然要遍历所有城市了。
            if(vis[j]){
                continue;
            }
            dfs(j);
            cnt++;
        }
        cout << cnt-1 << endl;
    }

    return 0;
}
/**
Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
**/

 

 

转载于:https://www.cnblogs.com/AbsolutelyPerfect/p/9502112.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值