PAT (Advanced Level) 1013 Battle Over Cities (25分)

PAT (Advanced Level) 1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting c i t y ​ 1 city​_1 city1- c i t y 2 city_2 city2and c i t y 1 city1 city1​- c i t y 3 city_3 city3 . Then if c i t y 1 city_1 city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway c i t y 2 city_2 city2​- c i t y 3 city_3 city3​​ .

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

#include <bits/stdc++.h>
using namespace std;
vector <int> graph[1005];
int vis[1005], x;
void dfs(int u){
    if (u == x) return;
    for (auto v : graph[u]){
        if (vis[v] || v == x) continue;
        vis[v] = 1;
        dfs(v);
    }
}
int n, m, k;
int main(){
    ios::sync_with_stdio(false);
    cin.tie(NULL);
    cin >> n >> m >> k;
    for (int i = 0; i < m; i++){
        int u, v;
        cin >> u >> v;
        graph[u].push_back(v);
        graph[v].push_back(u);
    }

    for (int i = 0; i < k; i++){
        memset(vis, 0, sizeof(vis));
        cin >> x;
        int cnt = 0;
        for (int j = 1; j <= n; j++){
            if (!vis[j] && j != x){
                dfs(j);
                cnt++;
            }
        }
        cout << cnt - 1<< "\n";
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值